
  











    
    
        <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.goskagit.com/content/tncms/live/" />
<meta name="keywords" content="profiles, mount_vernon_high_school, profiles" />
<meta name="news_keywords" content="profiles, mount_vernon_high_school, profiles" />
<meta name="description" content="School: Mount Vernon High School" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=432183914" />
<meta name="google-play-app" content="app-id=com.skagitvalleyherald.android" />
<meta name="google-site-verification" content="m1abCaSzV9lhI5wMoN4WmKreTABS8R_rZtynrWXcYG0" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.goskagit.com/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=472%2C630" />
<meta property="og:image:width" content="472" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="Boon, Megan" />
<meta property="og:description" content="School: Mount Vernon High School" />
<meta property="og:site_name" content="goSkagit" />
<meta property="og:section" content="Class of 2020" />
<meta property="fb:app_id" content="2959550254137794" />
<meta property="article:publisher" content="https://www.facebook.com/SkagitValleyHerald" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@goskagit" />
<meta name="twitter:image:alt" content="Boon, Megan" />
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/png_core/resources/styles/png.css?_dc=1589266897"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.98968f638d68f28a0f12493ae176ad84.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/global/resources/styles/graduations.css?_dc=1588600159"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,400i,700,700i|Raleway:700,700i,900,900i"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/styles/site.css?_dc=1586892249"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<style>/*<![CDATA[*/ #block-1560643 .search-spinner { position: absolute; } #block-1560643 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1560643 { margin-bottom: 0; } #site-search-1560643 .site-search-form { padding: 0; } #site-search-1560643 #site-search-1560643-btn { outline: none; } #site-search-1560643 #site-search-1560643-term { border: 0; box-shadow: none; } #site-search-1560643 .site-search-form { box-shadow: none; } #user-controls-1538839 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1538839 .tn-user-screenname, #user-controls-1538839 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1538839 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1538839 .dropdown-signup { font-size: 12px; } #user-controls-1538839 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1538839 .large-user-avatar { margin-right: 10px; } #user-controls-1538839 .large-user-controls { font-size: 12px; } #user-controls-1538839 .logout-btn { cursor: pointer; } #user-controls-1538839 .user-welcome { color: #ffffff; } #user-controls-1538839 .login-btn { color: #fff!important; } #tncms-block-1847760 .tnt-prop-img { max-width: 474px; } #site-logo-1847760 { color: #666; } @media screen and (min-width: 320px) { #ad-1536454 { min-height: 1px; min-width: 1px; } } @media screen and (min-width: 768px) { #ad-1536454 { min-height: 1px; min-width: 1px; } } @media screen and (min-width: 992px) { #ad-1536454 { min-height: 1px; min-width: 1px; } } @media screen and (min-width: 1200px) { #ad-1536454 { min-height: 1px; min-width: 1px; } } @media screen and (min-width: 320px) { #ad-1852742 { min-height: 50px; min-width: 320px; } } @media screen and (min-width: 768px) { #ad-1852742 { min-height: 50px; min-width: 320px; } } @media screen and (min-width: 992px) { #ad-1852742 { min-height: 90px; min-width: 728px; } } @media screen and (min-width: 1200px) { #ad-1852742 { min-height: 90px; min-width: 728px; } } @media screen and (min-width: 320px) { #ad-1852744 { min-height: 50px; min-width: 320px; } } @media screen and (min-width: 768px) { #ad-1852744 { min-height: 50px; min-width: 320px; } } @media screen and (min-width: 992px) { #ad-1852744 { min-height: 90px; min-width: 728px; } } @media screen and (min-width: 1200px) { #ad-1852744 { min-height: 90px; min-width: 728px; } } #block-1852116 .search-spinner { position: absolute; } #block-1852116 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1852116 .list-inline { font-size: 12px; } #site-search-1852116-btn { background-color: #de6942; border-color: #de6942; } #site-search-1852116-btn { color: #ffffff; } .fullscreen-region #block-1852116 { margin-top: 0px; margin-left: -15px; margin-right: -15px; } #block-1852116 .content-background{ position: relative; z-index: 1; } #block-1852116.light .content-background{ background-color: rgba(0,0,0,.9); } #block-1852116.dark .content-background{ background-color: rgba(255,255,255,.9); } #search-form-1852116.search-form-container .centered-content-container { text-align: center; padding: 15px; } #search-form-1852116.search-form-container .centered-content { max-width: 65%; } #search-form-1852116.search-form-container .img-responsive{ width: 100%; } #block-1852116 form { margin-bottom: 10px; } @media screen and (min-width: 320px) { #ad-1852743 { min-height: 50px; min-width: 320px; } } @media screen and (min-width: 768px) { #ad-1852743 { min-height: 50px; min-width: 320px; } } @media screen and (min-width: 992px) { #ad-1852743 { min-height: 90px; min-width: 728px; } } @media screen and (min-width: 1200px) { #ad-1852743 { min-height: 90px; min-width: 728px; } } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"mobile_pattern","style":"default","path":"\/classof2020\/profiles","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":214},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"mobile_pattern","style":"default","path":"\/classof2020\/profiles","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"vendor":{"outbrain":"disabled","taboola":""},"system":{"render_time":214},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469","app":"editorial"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-WZ9XB6D');})();</script>
<script src="//tags.crwdcntrl.net/c/9940/cc.js?ns=_cc9940" id="LOTCC_9940"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc9940.add('tp', 'TNNW');
		_cc9940.add('act', ' User Login');
		_cc9940.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc9940.bcp();
</script>

<script src="//s.ntv.io/serve/load.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/scripts/invisibly.js?_dc=1558646213"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["profiles","mount_vernon_high_school","profiles"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.chicago2.vip.townnews.com\/goskagit.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.e2581800cba1f328853618263e9a8b3f.js",
        pageCurl:"https:\/\/bloximages.chicago2.vip.townnews.com\/goskagit.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.chicago2.vip.townnews.com\/goskagit.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.562ac43ab5c59b0f315e3f7aabdfac51.js",
        paw:"https:\/\/bloximages.chicago2.vip.townnews.com\/goskagit.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.chicago2.vip.townnews.com\/goskagit.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.chicago2.vip.townnews.com\/goskagit.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        video:"https:\/\/bloximages.chicago2.vip.townnews.com\/goskagit.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.chicago2.vip.townnews.com\/goskagit.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/skagit/svh/classof2020/profiles';
            
                gptAdSlots['ad-1536454'] = googletag.defineSlot(adUnit, [1,1], 'ad-1536454').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/skagit/svh/classof2020/profiles';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,50],[300,250]]).addSize([768, 0], [[320,50],[300,250]]).addSize([992, 0], [728,90]).addSize([1200, 0], [[728,90],[970,250]]).build();
                gptAdSlots['ad-1852742'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[728,90],[970,250]], 'ad-1852742').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1852742'].setTargeting('pos', ['top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/30582678/skagit/svh/classof2020/profiles';
            
                gptAdSlots['ad-instory-middle'] = googletag.defineSlot(adUnit, [300,250], 'ad-instory-middle').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-instory-middle'].setTargeting('pos', ['png_top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/1033525/goskagit_SPORTS_BTF_300x250';
            
                gptAdSlots['ad-instory-bottom'] = googletag.defineSlot(adUnit, [300,250], 'ad-instory-bottom').setCollapseEmptyDiv(true).addService(googletag.pubads());
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/skagit/svh/classof2020/profiles';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,50],[300,250]]).addSize([768, 0], [[320,50],[300,250]]).addSize([992, 0], [728,90]).addSize([1200, 0], [[728,90],[970,250]]).build();
                gptAdSlots['ad-1852744'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[728,90],[970,250]], 'ad-1852744').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1852744'].setTargeting('pos', ['middle']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/94837440/skagit/svh/classof2020/profiles';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320,50],[300,250]]).addSize([768, 0], [[320,50],[300,250]]).addSize([992, 0], [728,90]).addSize([1200, 0], [[728,90],[970,250]]).build();
                gptAdSlots['ad-1852743'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[728,90],[970,250]], 'ad-1852743').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1852743'].setTargeting('pos', ['bottom']);
    });
 /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Boon, Megan | Class of 2020 | goskagit.com</title>

<!--
           `:ohdmNMNNmhs/`   -ssssssss`         ./oyhdmmmmdhyo:.           
        `+dMMMMMMMMMMMMMMNy. hMMMMMMMh      `/ymMMMMMMMMMMMMMMMMmy/`       
      `oNMMMMMMMMMMMMMMMMMMNoMMMMMMMM:    .sNMMMMMMMMN:yNMMMMMMMMMMNs.     
     -dMMMMMMMMNds/::/+ymMMMMMMMMMMMm   `sNMMMMMMMMMMMs .smMMMMMMMMMMNo`   
    :NMMMMMMMNy-        `oMMMMMMMMMM+  -dMMMMMMMMNNNmdh`  `:ymNMMMMMMMMd-  
   -NMMMMMMMN/            yMMMMMMMMN` -NMMMMmhs/:-``         `-+ymNMMMMMN- 
  `dMMMMMMMM:             /MMMMMMMMs `mMMNs:`                  `.:omMMMMMd`
  :MMMMMMMMy              +MMMMMMMN. +MMy.          ``.     `:sdNMMMMMMMMM/
  sMMMMMMMM:              dMMMMMMMy  yMd`       `-oydmh` `:ymMMMMMMMMMMMMMy
  yMMMMMMMM:             oMMMMMMMM:  hMo       -hNMMMM/.odMMMMMMMMMMMMMMMMh
  oMMMMMMMMy           `oMMMMMMMMd   oMh      `dMMMMMNsmMMMMMMMMMMMMMMMMMMo
  .NMMMMMMMMs.       ./dMMMMMMMMM/   .NN/     `mMMMMMMMMMMMMMMMMMMMMMMMMMN.
   +MMMMMMMMMmho+++shmMMMMMMMMMMm`    /MN/     oMMMMMMMMMMMMMMMMMMMMMMMMM/ 
    /mMMMMMMMMMMMMMMMMMNMMMMMMMMo      +NMy.   `yMMMMMMMMMMMMMMMMMMMMMMN+  
     .+dNMMMMMMMMMMMNh/hMMMMMMMN`       :dMm+`  `oNMMMMMMMMMMMMMMMMMMMd:   
       `./oyhdddhys/. /MMMMMMMMs         `+dMmo-  :dMMMMMMMMMMMMMMMMd+`    
.........    ```     -NMMMMMMMN.           `:ymNd+-`/dMMMMMMMMMMMms:`      
dNNNNNNNm.          /NMMMMMMMN:               `-+shhysyMMMMNmhs+-`         
+MMMMMMMMmo-`   `./hMMMMMMMMN/                     ``..-..``               
 +NMMMMMMMMMNNmmNNMMMMMMMMMh.                                              
  .odMMMMMMMMMMMMMMMMMMMms-                                                
     ./oydmNMMMMNNmdyo/.                                                   
-->
<script>(function(a,b,c,d,e){e=a.createElement(b);a=a.getElementsByTagName(b)[0];e.async=1;e.src=c;a.parentNode.insertBefore(e,a)})(document,'script','//straightnest.com/538885db1369975c328975517b7c34ab25980edcd65bc7818cd44eddf2962a87ac7829fb7804a6ab6145a010869e6bb5e8d45e8290f51777687937ae5f95');</script>

            
    <style>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</style> <link rel="shortcut icon" href="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/svh-logo-fav.png?_dc=1530217337"> <style> /* Rules for premium icon */ .headline-list .premium-asset-icon { margin-left: 0; margin-right: 0; } </style> <style> .navbar-toggle { float: left;} #tncms-region-main-nav-left-region{ float: left; width: 40%;} #tncms-region-nav-main-nav{ float: left; width: 60%;} .ad-no-margin .tnt-ads{margin-bottom: 0 !important} </style>
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/e14bdaa4-89a9-11e7-be8e-ab591f59d12c.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Boon, Megan | Class of 2020 | goskagit.com" href="http://www.goskagit.com/search/?f=rss&amp;t=article&amp;c=classof2020/profiles&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.goskagit.com/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html" />
            
    <script defer src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
            


    <script>
        document.onreadystatechange = function () {
            if (document.readyState == "complete") {
                var oSubButton =  document.querySelector(".meter.message .btn.btn-default.logged-in");
                if (oSubButton) {
                    
                        oSubButton.href ='https://svhoffers.com/';
                    
                }
                var oMessageLink = document.querySelector('#notification-area > div > p > span.logged-in > a');
                if (oMessageLink) {
                    if (oMessageLink.innerHTML = 'purchase a subscription') {
                        
                            oMessageLink.setAttribute('href','https://svhoffers.com/');
                        
                    }
                }
            }
        }
    </script>   


<!-- page app is editorial url is /classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html--><!-- loading site js -->
        </head>
        <body class="fixed-scroll-nav app-editorial grid-mobile-pattern blox-asset uuid-fc2a311f-3ad2-5437-95d4-9aef5d7b3469 section-classof2020section-profiles type-article infinity-disabled" data-path="/classof2020/profiles">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.goskagit.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=mobile_pattern&tncms.page.style=default&tncms.page.path=%2Fclassof2020%2Fprofiles&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.vendor.outbrain=disabled&tncms.vendor.taboola=&tncms.system.render_time=214&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.asset.id=fc2a311f-3ad2-5437-95d4-9aef5d7b3469&tncms.asset.app=editorial&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-WZ9XB6D&tncms.template.version=3.155.0&tncms.page.grid=mobile_pattern&tncms.page.style=default&tncms.page.path=%2Fclassof2020%2Fprofiles&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.vendor.outbrain=disabled&tncms.vendor.taboola=&tncms.system.render_time=214&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.asset.id=fc2a311f-3ad2-5437-95d4-9aef5d7b3469&tncms.asset.app=editorial&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container">
        
        
    
        
            
                <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left ">
                    <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1555859" class="tncms-block">
<div id="site-brand-mark-1555859" class="tncms-block site-brand-mark">
        <section class="block emphasis-h3">
            <div class="block">
                <a href="/"><img class="img-responsive" alt="goSkagit" src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/svh-logo-btn.png?_dc=1523995446"></a></div>
        </section>
    </div>
    <div id="site-follow-us-1555859" class="tncms-block site-follow-us">
        <div class="default">
            <section class="block emphasis-h3">
                <ul class="list-inline">
                    <li><a class="btn btn-xs btn-link fb" href="/newsletter/subscribe" target="_blank" title="Newsletter"><span class="far tnt-envelope"></span></a></li><li><a class="btn btn-xs btn-link fb" href="https://www.facebook.com/SkagitValleyHerald" target="_blank" title="Facebook"><span class="fab tnt-facebook-f"></span></a></li><li><a class="btn btn-xs btn-link fb" href="http://www.twitter.com/goskagit" target="_blank" title="Twitter"><span class="fab tnt-twitter"></span></a></li><li><a class="btn btn-xs btn-link fb" href="https://www.youtube.com/user/skagitvalleyherald" target="_blank" title="YouTube"><span class="fab tnt-youtube"></span></a></li></ul>
            </section>
        </div>
        <div class="clearfix"></div>
    </div></div><div id="tncms-block-1560643" class="tncms-block mysterySideSearch"><section id="block-1560643" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-1560643" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-1560643" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-sm form-control">
        <input id="site-search-1560643-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1560643-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1560643-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1560643').submit();
        return false;
    });

    $('#site-search-1560643').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1560643 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1560643 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1560643-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-1538839" class="tncms-block meGoCenter"><div id="user-controls-1538839" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.goskagit.com/users/signup/?referer_url=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.goskagit.com/users/login/?referer_url=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.goskagit.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-1538839').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.goskagit.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.goskagit.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.goskagit.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-1538839').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.goskagit.com/users/logout/" id="user-logout-form-1538839"><input type="hidden" name="referer_url" value="https://www.goskagit.com/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1538841" class="tncms-block"><div class="tncms-block site-nav-sections-header">
  <section class="block emphasis-h3"><div class="clearfix">
      <ul class="list-inline block-links pos-top" style="text-align:center;">
<li>
          <a class="" href="https://svhoffers.com">
            <span style="color:#ff9900;">Subscribe today!</span>
          </a>
        </li>
      </ul>
<div class="drawer-title">
        <div class="drawer-title-inner">
          <h3>Sections</h3>
        </div>
      </div>
    </div>
  </section>
</div></div></div>
                    <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/"  class="nav-link tnt-section-back-to-goskagit">Back to goSkagit</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/classof2020/"  class="nav-link tnt-section-class-of-2020">Class of 2020</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/classof2020/submit_profile/"  class="nav-link tnt-section-submit-graduate-profile">Submit graduate profile</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a href="/classof2020/search/?q=%20&amp;c%5B%5D=virtual_graduations/profiles&amp;sd=desc&amp;l=10&amp;nsa=eedition"  class="nav-link tnt-section-search-profiles">Search profiles</a>
                        </div>
                    </div></div></div></div>
                    
                    <div id="tncms-region-mobile-nav-middle-left-region" class="tncms-region "><div id="tncms-block-1538837" class="tncms-block"><div class="tncms-region-nav" id="htmlHardcoded-region-nav-mobile-nav-left-middle">
  <div class="panel-group nav navbar-nav" id="mobile-nav-left-middle_menu" role="tablist">
    <div class="panel panel-default">
      <div class="panel-heading" role="tab">
        <div class="panel-title">
          <a href="/directory"><span class="topbarLink"><i aria-hidden="true" class="fas tnt-map-marker-alt"></i> Business Directory</span></a>
        </div>
      </div>
    </div>
    <div class="panel panel-default">
      <div class="panel-heading" role="tab">
        <div class="panel-title">
          <a href="/eedition/"><span class="topbarLink"><i aria-hidden="true" class="fas tnt-newspaper"></i> Read the E-Edition</span></a>
        </div>
      </div>
    </div>
  </div>
</div></div></div>
                    <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "><div id="tncms-block-1538838" class="tncms-block"><div class="tncms-region-nav" id="htmlHardcoded-region-nav-mobile-nav-left-below">
  <div class="panel-group nav navbar-nav" id="mobile-nav-left-bottom_menu" role="tablist">
    <div class="panel panel-default">
      <div class="panel-heading" role="tab">
        <div class="panel-title">
          <a aria-controls="mobile-nav-left-bottom_menu-child-1" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-1" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/customerservice/"><i aria-hidden="true" class="fas tnt-cog"></i> Subscriber Services</a>
        </div>
      </div>
      <ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-1">
<li><a href="/subscribe/">Start A Subscription</a></li>
        <li><a href="http://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=SVP" target="_blank">Manage Subscription</a></li>
        <li><a href="http://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=SVP" target="_blank">Make A Payment</a></li>
        <li><a href="http://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=SVP" target="_blank">Vacation Stop</a></li>
        <li><a href="/site/forms/subscription_services/deliveryissue/">Report A Delivery Issue</a></li>
        <li><a href="/newsletter/subscribe/">Get our newsletters</a></li>
      </ul>
</div>
    <div class="panel panel-default">
      <div class="panel-heading" role="tab">
        <div class="panel-title">
          <a aria-controls="mobile-nav-left-bottom_menu-child-2" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-2" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a><i aria-hidden="true" class="fas tnt-bullhorn"></i> Make An Announcement</a>
        </div>
      </div>
      <ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-2">
<li><a href="/site/forms/online_services/birthdays/birthday_announcement/">Birthdays</a></li>
        <li><a href="/site/forms/online_services/engagements/engagement_announcement/">Engagement</a></li>
        <li><a href="/site/forms/online_services/weddings/wedding_announcements/">Wedding</a></li>
        <li><a href="/site/forms/online_services/births/birth_announcement/">Birth</a></li>
        <li><a href="/site/forms/online_services/anniversaries/aniversary_announcement/">Anniversary</a></li>
      </ul>
</div>
    <div class="panel panel-default">
      <div class="panel-heading" role="tab">
        <div class="panel-title">
          <a aria-controls="mobile-nav-left-bottom_menu-child-3" aria-expanded="false" class="expand-children collapsed pull-right" data-target="#mobile-nav-left-bottom_menu-child-3" data-toggle="collapse"><i class="fas tnt-chevron-down"></i></a> <a href="/site/services"><i aria-hidden="true" class="fas tnt-cubes"></i> Site Services</a>
        </div>
      </div>
      <ul class="collapse nav navbar-nav" id="mobile-nav-left-bottom_menu-child-3">
<li><a href="/newsletter/subscribe/">Get our newsletters</a></li>
        <li><a href="/site/about/">About Us</a></li>
        <li><a href="/site/contact/">Contact Us</a></li>
        <li><a href="/site/advertising/">Advertising</a></li>
        <li><a href="https://classadz.vdata.com/Skagit/CustomerType.aspx" target="_blank">Place A Classified Ad</a></li>
        <li><a href="https://portal.cityspark.com/EventEntry/EventEntry/skagitvalleyherald" target="_blank">Add A Calendar Event</a></li>
        <!-- <li><a href="/site/rss/">RSS Feeds</a></li> -->
       </ul>
</div>
    <div class="panel panel-default">
      <div class="panel-heading" role="tab">
        <div class="panel-title">
          <a href="http://nl.newsbank.com/sites/pngnp/"><span class="topbarLink"><i class="fas tnt-list-ul"></i> Browse the archives</span></a>
        </div>
      </div>
    </div>
  </div>
</div></div></div>
                </aside>
            
            
    
            <div class="offcanvas-inner">
                <div class="offcanvas-close-btn"></div>
        
    
        
    
        
    
        
            <div id="site-navbar-container" class="hidden-print affix-top">
                
                <nav id="main-navigation" class="navbar yamm navbar-default container">
                    
                    <div class="navbar-header">
                        
                        
                            <button type="button" class=" hamburger-desktop fluid-header navbar-toggle " data-toggle="offcanvas" data-target="left">
                                <span class="sr-only">Toggle navigation</span>
                                <span class="icon-bar" style='margin: 0 auto 4px auto;'></span>
                                <span class="icon-bar" style='margin: 0 auto 4px auto;'></span>
                                <span class="icon-bar" style='margin: 0 auto;'></span>
                                <span class="visible-lg visible-md sr-only-show">Full Menu</span>
                            </button>
                            
                        
                        
    
                        
                            <div class="navbar-brand hidden-md hidden-lg pos_left">
                                
                                    <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1555481" class="tncms-block">
<div id="site-logo-1555481" class="site-logo-container swap-site-mobile">
        <div class="logo-middle swap-site-mobile-current">
            <a href="/" title="goSkagit"><img class="img-responsive" alt="goSkagit" src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/svh-logo-mobile.png?_dc=1523995471"></a><div id="swap-site-mobile-choice-trigger"><i class="fas tnt-chevron-down" aria-hidden="true"></i></div>
        </div>
        <div id="swap-site-mobile-choices">
            <a href="/" title="goSkagit"><img class="img-responsive" alt="goSkagit" src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/svh-logo-btn-sm.png?_dc=1523995435">goSkagit</a><a href="/anacortes" title="goAnacortes"><img class="img-responsive" alt="goAnacortes" src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/gac-logo-btn-sm.png?_dc=1523995334">goAnacortes</a><a href="/scnews" title="SC News"><img class="img-responsive" alt="SC News" src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/scn-logo-btn-sm.png?_dc=1523995379">SC News</a><a href="/360" title="Entertainment 360"><img class="img-responsive" alt="Entertainment 360" src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/360-logo-btn-sm.png?_dc=1525104728">Entertainment 360</a><a href="/growskagit" title="Grow Skagit"><img class="img-responsive" alt="Grow Skagit" src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/images/logos/svh-logo-btn-sm.png?_dc=1523995435">Grow Skagit</a></div>
    </div></div><div id="tncms-block-1847759" class="tncms-block"><h2 class="mobile-heading hidden-lg hidden-md"><a href="/virtual_graduations/" style="color: rgba(165, 222, 241,.6) !important;">2020 Graduation</a></h2></div></div>
                                
                            </div>
                        
    
                                        
                    </div>
    
                    
                        <div id="navbar-collapse" class="navbar-collapse collapse">
                            
                                <div class="pull-right">
                                    <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                    <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link  tnt-section-submit-profiles"  href="/classof2020/submit_profile/" >
                    <span class="nav-label">Submit Profiles</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/classof2020/search/?q=%20&amp;c%5B%5D=classof2020/profiles&amp;sd=asc&amp;=title&amp;t=article&amp;l=10&amp;nsa=eedition" >
                    <span class="nav-label">Search</span>
                </a></li></ul></div>
                                </div>
                            
                            <div class="navbar-left">
                                <div id="tncms-region-main-nav-left-region" class="tncms-region "><div id="tncms-block-1847760" class="tncms-block"><div id="site-logo-1847760" class="site-logo-container text-left" >
        <div class="logo-top"></div>
        <div class="logo-middle">
            <a  href="/"><img 
            
            src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/763eac56-8bf3-11ea-a268-77a0a5b76d7a.png?resize=200%2C52" 
            srcset="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/763eac56-8bf3-11ea-a268-77a0a5b76d7a.png?resize=200%2C52 200w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/763eac56-8bf3-11ea-a268-77a0a5b76d7a.png?resize=300%2C78 300w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/763eac56-8bf3-11ea-a268-77a0a5b76d7a.png?resize=400%2C104 400w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/763eac56-8bf3-11ea-a268-77a0a5b76d7a.png 540w"
            sizes="100vw"
            class=" img-responsive lazyload tnt-prop-img"
            alt="site-logo"></a>
        </div>
        <div class="logo-bottom"></div>
    </div></div></div>
                                <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link  tnt-section-class-of-2020"  href="/classof2020/" >
                    <span class="nav-label">Class of 2020</span>
                </a></li></ul></div>
                            </div>
                        </div>
                    
    
                    
                </nav>
                
            </div>
            
                
                    <script>
                        jQuery(document).ready(function($){
                            var sNavContainer = '#site-navbar-container';
                            var sBodyContainer = '#main-body-container';
                            var sNavHeight = $(sNavContainer).height();
                            var iUnfixPoint = 0;
                            if( __tnt.client.platform.ios ){
                                $(sNavContainer).addClass('affix-sticky');
                            } else {
                                $sNavScroll = false;
                                $(window).on('scroll mousewheel', function(){
                                    if( !$sNavScroll ){
                                        $sNavScroll = true;
                                        setTimeout(function(){
                                            var iFixPoint = $(sNavContainer).offset().top;
                                            var iCurrPoint = $(this).scrollTop();
                                            if( iCurrPoint >= iFixPoint && iCurrPoint > iUnfixPoint ){
                                                if( !$(sNavContainer).hasClass('affix') ){ 
                                                    iUnfixPoint = iFixPoint;
                                                    $(sNavContainer).addClass('affix').removeClass('affix-top');
                                                    $(sBodyContainer).css('margin-top', sNavHeight+'px'); 
                                                }
                                            } else {
                                                if( !$(sNavContainer).hasClass('affix-top') ){ 
                                                    $(sNavContainer).removeClass('affix').addClass('affix-top');
                                                    $(sBodyContainer).css('margin-top', 0);
                                                }
                                            }
                                            $sNavScroll = false;
                                        }, 25);
                                    }
                                });
                            }
                        });
                    </script>
                
            
        
        <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1536454" class="tncms-block ad-no-margin"><div class="tnt-ads-container text-center  " >
        <div id="ad-1536454" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1536454');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "></div></div>
        </div><div id="modal-image-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a" class="modal fullscreen in modal-image image-default modal-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-vertical letterbox-style-blur">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=400%2C533"
                    srcset="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=200%2C267 200w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=300%2C400 300w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=400%2C533 400w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=540%2C720 540w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=750%2C1000 750w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=1200%2C1600 1200w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg 1700w"
                    sizes="100vw"
                    width="1247"
                    height="1663"
                    alt="Boon, Megan"
                    class="img-responsive true-size blur" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a" data-target=".caption-inner-modal-image-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Fimage_463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/classof2020/profiles/boon-megan/image_463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Boon%2C%20Megan&via=goskagit&url=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Fimage_463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/classof2020/profiles/boon-megan/image_463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.goskagit.com/classof2020/profiles/boon-megan/image_463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/classof2020/profiles/boon-megan/image_463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.goskagit.com/tncms/asset/editorial/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSkagit%20Valley%20Herald%5D%20Boon%2C%20Megan&body=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Fimage_463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/classof2020/profiles/boon-megan/image_463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a" class="save-list-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a img { max-height: 760px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-fc2a311f-3ad2-5437-95d4-9aef5d7b3469" class="asset article-default"  data-url="https://www.goskagit.com/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=472%2C630">
            <meta itemprop="width" content="472">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="goskagit.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.goskagit.com/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html" />
    <div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.goskagit.com\/tncms\/search\/mlt\/?origin=fc2a311f-3ad2-5437-95d4-9aef5d7b3469&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-fc2a311f-3ad2-5437-95d4-9aef5d7b3469" class="asset-paging">
                <div id="paging-prev-fc2a311f-3ad2-5437-95d4-9aef5d7b3469" class="paging-link prev offset"></div>
                <div id="paging-next-fc2a311f-3ad2-5437-95d4-9aef5d7b3469" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Boon, Megan
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2020-06-09T00:00:00-07:00" class="tnt-date asset-date text-muted">
            Jun 9, 2020
        </time>
    </li>
            <li class="hidden-print">
        <time datetime="2020-06-09T00:00:00-07:00" class="tnt-date asset-date text-muted">21 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-06-09T00:00:00-07:00">
    <meta itemprop="datePublished" content="2020-06-09T00:00:00-07:00">
    <meta itemprop="dateModified" content="2020-06-09T00:00:00-07:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Boon%2C%20Megan&via=goskagit&url=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.goskagit.com/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.goskagit.com/tncms/asset/editorial/fc2a311f-3ad2-5437-95d4-9aef5d7b3469" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSkagit%20Valley%20Herald%5D%20Boon%2C%20Megan&body=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-vertical hover-expand letterbox-style-blur"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1247">
            <meta itemprop="height" content="1663">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=500%2C667">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=500%2C667">
        <img
                    src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=400%2C533"
                    srcset="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=200%2C267 200w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=300%2C400 300w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=400%2C533 400w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=540%2C720 540w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=750%2C1000 750w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=1200%2C1600 1200w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg 1700w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), 100vw"
                    width="1247"
                    height="1663"
                    alt="Boon, Megan"
                    class="img-responsive  letterbox tnt-restrict-img-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a blur" />
            </div><div class="tnt-blurred-image">
             <img src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/assets/v3/editorial/4/63/463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a/5ee054814ccb2.image.jpg?resize=200%2C267"/>
         </div><style>
                .tnt-restrict-img-463fa1c6-24f9-5fee-a0ec-02b5eddf7a0a {
                    max-width: 570px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"><div id="tncms-block-1852742" class="tncms-block ad-background"><div class="tnt-ads-container text-center  " >
        <div id="ad-1852742" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1852742');
                        
                });
            </script>
        </div>
    </div>
</div></div>

            <div id="asset-content" data-asset-uuid="fc2a311f-3ad2-5437-95d4-9aef5d7b3469">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Boon%2C%20Megan&via=goskagit&url=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.goskagit.com/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.goskagit.com/tncms/asset/editorial/fc2a311f-3ad2-5437-95d4-9aef5d7b3469" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSkagit%20Valley%20Herald%5D%20Boon%2C%20Megan&body=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-fc2a311f-3ad2-5437-95d4-9aef5d7b3469-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="fc2a311f-3ad2-5437-95d4-9aef5d7b3469" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="fc2a311f-3ad2-5437-95d4-9aef5d7b3469" class="save-list-fc2a311f-3ad2-5437-95d4-9aef5d7b3469-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="fc2a311f-3ad2-5437-95d4-9aef5d7b3469" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p><strong>School:</strong> Mount Vernon High School</p><p><strong>Future plans:</strong> Megan is going to be attending the ATTIC program in Burlington</p><div class="tnt-ads-container text-center  " >
        <div id="ad-instory-middle" class="tnt-ads dfp-ad" style="min-height:px; min-width:300250px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-instory-middle');
                        
                });
            </script>
        </div>
    </div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p><strong>Extracurriculars:</strong> Megan has been involved with 4H for 8 years now, along with Special Olympics And Unified Soccer</p><p><strong>Parents' names:</strong> Steve and Melinda Boon</p><div class="hidden-sm hidden-xs hidden-print"><div class="tnt-ads-container text-center  " >
        <div id="ad-instory-bottom" class="tnt-ads dfp-ad" style="min-height:px; min-width:300250px;" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-instory-bottom');
                        
                });
            </script>
        </div>
    </div></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"><div id="tncms-block-1852744" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1852744" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1852744');
                        
                });
            </script>
        </div>
    </div>
</div></div>
                                
                            </div>

                            

                            
    <div class="related-by-section hidden-print block emphasis-h4">
        <div class="block-title">
            <div class="block-title-inner">
                <h4>More from this section</h4>
            </div>
        </div>
        <ul class="list-unstyled">
            
            <li>
                <h4 style="line-height: 1.2em">
                    <a href="/classof2020/profiles/mcnerney-katherine/article_513a9f10-bf01-5ef9-96a8-241b66c2c10a.html/#utm_source=goskagit.com&utm_campaign=related-by-section&utm_medium=direct&utm_term=mcnerney%2C%20katherine">McNerney, Katherine</a><br />
                    <small><span class="fas tnt-clock"></span> Posted:  June 9, 2020</small>
                </h4>
            </li>
            
            <li>
                <h4 style="line-height: 1.2em">
                    <a href="/classof2020/profiles/de-la-vergne-nathaniel/article_d273c706-c31a-5ad0-9df3-c16f15d81ef2.html/#utm_source=goskagit.com&utm_campaign=related-by-section&utm_medium=direct&utm_term=de%20la%20vergne%2C%20nathaniel">De La Vergne, Nathaniel</a><br />
                    <small><span class="fas tnt-clock"></span> Posted:  June 9, 2020</small>
                </h4>
            </li>
            
            <li>
                <h4 style="line-height: 1.2em">
                    <a href="/classof2020/profiles/sustaita-miguel/article_704dd100-ab03-5bea-abcc-2d8ee95c295c.html/#utm_source=goskagit.com&utm_campaign=related-by-section&utm_medium=direct&utm_term=sustaita%2C%20miguel">Sustaita, Miguel</a><br />
                    <small><span class="fas tnt-clock"></span> Posted:  June 9, 2020</small>
                </h4>
            </li>
            
            <li>
                <h4 style="line-height: 1.2em">
                    <a href="/classof2020/stanwood_high_school/eldridge-taylor/article_f02444ef-3288-5577-be99-0d7abf6c5a1e.html/#utm_source=goskagit.com&utm_campaign=related-by-section&utm_medium=direct&utm_term=eldridge%2C%20taylor">Eldridge, Taylor</a><br />
                    <small><span class="fas tnt-clock"></span> Posted:  June 8, 2020</small>
                </h4>
            </li>
            
            <li>
                <h4 style="line-height: 1.2em">
                    <a href="/classof2020/profiles/hagedorn-hayli/article_f92b0568-b43e-5496-85ff-bf5df8229976.html/#utm_source=goskagit.com&utm_campaign=related-by-section&utm_medium=direct&utm_term=hagedorn%2C%20hayli">Hagedorn, Hayli</a><br />
                    <small><span class="fas tnt-clock"></span> Posted:  June 8, 2020</small>
                </h4>
            </li>
            
        </ul>
    </div><!-- .related-by-section -->
    <div id="tncms-region-asset-native-advertising" class="tncms-region "></div>
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Boon%2C%20Megan&via=goskagit&url=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.goskagit.com/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.goskagit.com/tncms/asset/editorial/fc2a311f-3ad2-5437-95d4-9aef5d7b3469" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BSkagit%20Valley%20Herald%5D%20Boon%2C%20Megan&body=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"fc2a311f-3ad2-5437-95d4-9aef5d7b3469"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-fc2a311f-3ad2-5437-95d4-9aef5d7b3469-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="fc2a311f-3ad2-5437-95d4-9aef5d7b3469" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="fc2a311f-3ad2-5437-95d4-9aef5d7b3469" class="save-list-fc2a311f-3ad2-5437-95d4-9aef5d7b3469-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="fc2a311f-3ad2-5437-95d4-9aef5d7b3469" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-1852116" class="tncms-block grad-search"><section id="block-1852116" class="block emphasis-h3 light  text-shadow " >
    <div class="clearfix"></div>
    <div id="search-form-1852116" class="search-form-container card clearfix text-center hidden-print ">
    
        <div class="centered-content-stage">
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/6aa43700-a45b-11ea-b783-d35176d7a605.jpg?resize=200%2C62 200w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/6aa43700-a45b-11ea-b783-d35176d7a605.jpg?resize=300%2C94 300w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/6aa43700-a45b-11ea-b783-d35176d7a605.jpg?resize=400%2C125 400w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/6aa43700-a45b-11ea-b783-d35176d7a605.jpg?resize=540%2C169 540w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/6aa43700-a45b-11ea-b783-d35176d7a605.jpg?resize=750%2C234 750w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/6aa43700-a45b-11ea-b783-d35176d7a605.jpg?resize=1200%2C375 1200w, https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/6aa43700-a45b-11ea-b783-d35176d7a605.jpg 1700w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt=""><div class="centered-content-container content-overlay ">
                <div class="centered-content ">
    <div class="card-headline">
            <h1>Find your graduate</h1>
        </div>
    <form id="site-search-1852116" action="/classof2020/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="title">
        <input type="hidden" name="sd" value="asc">
    
    
        <input type="hidden" name="c[]" value="classof2020/profiles">
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default input-group-lg ">
        <input id="site-search-1852116-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1852116-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        <ul class="list-inline block-links pos-content ">
            
                
                    <li><a href="/classof2020/submit_profile" class="h4"><i class="fas tnt-plus"></i> Submit a student profile</a></li>
                
            
            
        </ul>
        
                    </div>
                </div>
            </div>
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-1852116-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1852116').submit();
        return false;
    });

    $('#site-search-1852116').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1852116 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1852116 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-1852116-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-1852743" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1852743" class="tnt-ads dfp-ad" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1852743');
                        
                });
            </script>
        </div>
    </div>
</div></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="fc2a311f-3ad2-5437-95d4-9aef5d7b3469" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/classof2020/profiles/boon-megan/article_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="fc2a311f-3ad2-5437-95d4-9aef5d7b3469" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.goskagit.com/users/login/?referer_url=https%3A%2F%2Fwww.goskagit.com%2Fclassof2020%2Fprofiles%2Fboon-megan%2Farticle_fc2a311f-3ad2-5437-95d4-9aef5d7b3469.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-top" class="tncms-region "></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "></div><div id="tncms-region-global-side-middle" class="tncms-region "></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-bottom" class="tncms-region "></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1691593" class="tncms-block"><style>
	#tncms-block-1691593 {
		display: none;
		position: fixed;
		bottom: 0;
		z-index: 300;
		left: 50%;
		-webkit-transform: translateX(-50%);
		   -moz-transform: translateX(-50%);
			-ms-transform: translateX(-50%);
				transform: translateX(-50%);
		width: 100%;
		max-width: 900px;
	}
	#block-1691593 .block-title  {
		display: none;
	}
	.clearFix {
		clear: both;
	}
	.fop_promo {

	}
	.fop_heading {
		background-color: #1c354f;
		color: #ffffff;
		padding: 12px 24px;
		font-size: 16px;
		line-height: 24px;
		position: relative;
	}
	.fop_offerShort {
		float: left;
		padding-right: 24px;
	}
	.fop_login {
		float: right;
		padding-right: 36px;
		font-size: 14px;
	}
	.fop_login a {
		color: #ffffff;
		text-decoration: none;
	}
	.fop_login a:hover {
		color: #ffffff;
		text-decoration: underline;
	}
	.fop_close {
		position: absolute;
		top: 12px;
		right: 12px;
		width: 24px;
		height: 24px;
		text-align: center;
		font-size: 16px;
		cursor: pointer;
	}
	.fop_body {
		background-color: #f0f0f0;
		color: #222222;
		border-left: 1px solid rgba(0,0,0,0.25);
		border-right: 1px solid rgba(0,0,0,0.25);
		max-height: 0;
		-webkit-transition: all 300ms ease;
		transition: all 300ms ease;
	}
	#block-1691593:hover .fop_body {
		max-height: 1000px;
		border-bottom: 1px solid rgba(0,0,0,0.25);
	}
	.fop_body > div {
		display: inline-block;
		width: 33.333%;
		vertical-align: middle;
		padding: 24px 24px;
	}
	.fop_logo {
		text-align: center;
	}
	.fop_logo img {
		margin: 0 auto;
	}
	.fop_tagline {
		text-align: center;
		font-size: 16px;
		line-height: 24px;
	}
	.fop_offerLong {
		text-align: center;
	}
	.fop_offerLong .fop_offerText {
		text-align: left;
		margin-bottom: 12px;
	}
	.fop_offerLong .fop_offerLink {
		margin: 0 auto;
		border: 1px solid #1c354f;
		background-color: #1c354f;
		color: #ffffff;
		display:inline-block;
		padding:6px 15px;
		cursor: pointer;
		-webkit-transition: all 200ms ease;
		transition: all 200ms ease;
	}
	.fop_offerLink:hover {
		background-color: #ffffff;
		color: #1c354f;
		display:inline-block;
		padding:6px 15px;
		text-decoration: none;
	}
	.fop_offerLink:hover a {
		text-decoration: none;
	}
	@media screen and (max-width: 750px) {
		.fop_body > div {
			width: 100%;
			padding: 12px 24px;
		}
		.fop_body {
			padding: 0px 0px;
		}
		#block-1691593:hover .fop_body {
			padding: 12px 0px;
		}
		.fop_offerLong .fop_offerText {
			text-align: center;
		}
	}
</style>
<script>
(function($) {
$(function() {
	var thisBlock = $('#tncms-block-1691593');
	var thisBlockClose = $('#tncms-block-1691593 .fop_close');
	var urSet = $.cookie('tncms-services');
	var fopNo = $.cookie('fop_no');
	// user closed promo
	thisBlockClose.click(function(){
		thisBlock.css('display','none');
		$.cookie('fop_no', 1, { path: '/', expires: 7 });
	});
	// user is logged in or has previously closed promo
	if( ( urSet && urSet != '' ) || ( fopNo && fopNo != '' ) ) {
		thisBlock.css('display','none');
	} else {
		thisBlock.css('display','block');
	}
})
})(jQuery);
</script><section id="block-1691593" class="block emphasis- #222222 heading-color  " ><div class="clearfix">
    
    <div class="block-title title-1691593 #ffffff">
        <div class="block-title-inner">
            <h2>
                
                Footer Offer Promo
                
            </h2>
        </div>
    </div></div><div class="fop_promo invalid-subscribers-only">
	<div class="fop_heading">
		<div class="fop_offerShort">CARRIERS NEEDED!</div>
		
                <div class="fop_close"><i class="fas tnt-times" aria-hidden="true"></i></div>
		<div class="clearFix"></div>
	</div>
	<div class="fop_body">
		<div class="fop_logo"><img class="media-object img-responsive " src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/custom/image/8f3b12be-9da9-11e9-8404-e7351fb3b355.png" alt=""></div><div class="fop_tagline">Local News Worth Delivering
		</div><div class="fop_offerLong">
			<div class="fop_offerText">Become a newspaper carrier for the Skagit Valley Herald  and earn up to $1,500 a month.</div>
			<a href="/carrier/" class="fop_offerLink">Apply Today!</a>
		</div>
	</div>
</div></section></div><div id="tncms-block-1560357" class="tncms-block">
<div class="footerContainer-1560357 footerContainer footer-upper hidden-sm">
        <div class="cols-wrap">
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/" style="color:#fff;">News</a></li>
                <li class="col-item"><a href="/" title="goSkagit">goSkagit</a></li><li class="col-item"><a href="/anacortes" title="goAnacortes">goAnacortes</a></li><li class="col-item"><a href="/scnews" title="SC News">SC News</a></li><li class="col-item"><a href="/360" title="Entertainment 360">Entertainment 360</a></li><li class="col-item"><a href="/growskagit" title="Grow Skagit">Grow Skagit</a></li><li class="col-item"><a href="/eedition/" target="" title="E-Edition">E-Edition</a></li><li class="col-item"><a href="/classifieds/" target="" title="Classifieds">Classifieds</a></li><li class="col-item"><a href="/obituaries/" target="" title="Obituaries">Obituaries</a></li><li class="col-item"><a href="https://svhoffers.com/" target="_blank" title="Subscribe Today">Subscribe Today</a></li></ul>
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/site/services/" style="color:#fff;">Services</a></li><li class="col-item"><a href="mailto:news@skagitpublishing.com" target="" title="Email Newsroom">Email Newsroom</a></li><li class="col-item"><a href="mailto:ads@skagitads.com" target="" title="Email Advertising">Email Advertising</a></li><li class="col-item"><a href="mailto:circulation@skagitpublishing.com" target="" title="Email Circulation">Email Circulation</a></li><li class="col-item"><a href="mailto:classified@skagitpublishing.com" target="" title="Email Classified">Email Classified</a></li><li class="col-item"><a href="/site/forms/online_services/webissue/" target="" title="Website Issues">Website Issues</a></li><li class="col-item"><a href="mailto:circulation@skagitpublishing.com" target="" title="Report a Delivery Issue">Report a Delivery Issue</a></li><li class="col-item"><a href="https://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=SVP" target="_blank" title="Manage Your Subscription">Manage Your Subscription</a></li><li class="col-item"><a href="https://iservices.pioneernewsgroup.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=SVP" target="_blank" title="Pay Subscription Bill">Pay Subscription Bill</a></li><li class="col-item"><a href="/locations/" target="" title="Rack Locations">Rack Locations</a></li><li class="col-item"><a href="/community/community_room/" target="" title="Community Room">Community Room</a></li><li class="col-item"><a href="https://www.goskagit.com/scnews/phonebook/" target="_blank" title="Stanwood-Camano Phonebook">Stanwood-Camano Phonebook</a></li></ul>
            <ul class="footer-col footer-col-list col-md-3 col-sm-6 col-xs-12">
                <li class="col-heading"><a href="/site/forms/online_services/submit_news/" style="color:#fff;">Submissions</a></li><li class="col-item"><a href="https://classadz.vdata.com/MountVernonSkagitValleyHerald/Advertising/Advertiser" target="_blank" title="Place a Classified Ad">Place a Classified Ad</a></li><li class="col-item"><a href="https://portal.cityspark.com/EventEntry/EventEntry/skagitvalleyherald" target="_blank" title="Add a Calendar Event">Add a Calendar Event</a></li><li class="col-item"><a href="/site/forms/online_services/submit_news/" target="" title="Submit News">Submit News</a></li><li class="col-item"><a href="/site/forms/online_services/letter/" target="" title="Send a Letter to the Editor">Send a Letter to the Editor</a></li><li class="col-item"><a href="/site/forms/skagit/skagit_obit" target="_blank" title="Submit an Obituary">Submit an Obituary</a></li><li class="col-item"><a href="/site/forms/online_services/birthdays" target="" title="Birthday Announcement">Birthday Announcement</a></li><li class="col-item"><a href="/site/forms/online_services/engagements" target="" title="Engagement Announcement">Engagement Announcement</a></li><li class="col-item"><a href="/site/forms/online_services/weddings" target="" title="Wedding Announcement">Wedding Announcement</a></li><li class="col-item"><a href="/site/forms/online_services/births" target="" title="Birth Announcement">Birth Announcement</a></li><li class="col-item"><a href="/site/forms/online_services/anniversaries" target="" title="Anniversary Announcement">Anniversary Announcement</a></li><li class="col-item"><a href="/site/forms/skagit/carrier" target="" title="Carrier Application">Carrier Application</a></li></ul>
            <div class="footer-col footer-col-info col-md-3 col-sm-6 col-xs-12">
                <div class="footer-col-info-basic">
                    <div class="col-heading"><a href="/site/contact/" style="color:#fff;">Contact Us</a></div>
                    
                    <div class="col-item col-item-highlight">Skagit Valley Herald</div>
                    <div class="col-item"><a href="http://maps.google.com/maps?daddr=1215+Anderson+Rd+Mt+Vernon,+WA+98274" target="_blank">1215 Anderson Rd<br>Mt Vernon, WA 98274</a></div>
                    <div class="col-item"><a href="tel:3604243251">360-424-3251</a></div>
                    <div class="col-item"><a href="mailto:news@skagitpublishing.com">news@skagitpublishing.com</a></div><li class="col-item"><a href="/site/contact" target="" title="Contact Us">Contact Us</a></li><li class="col-item"><a href="/site/about" target="" title="About Us">About Us</a></li><li class="col-item"><a href="/site/contact" target="" title="<strong>Contact Stanwood Phonebook</strong>"><strong>Contact Stanwood Phonebook</strong></a></li></div>
                <div class="footer-col-info-social">
                    <div class="col-heading">Follow Us</div><div class="col-item-icon"><a href="/newsletter/subscribe" target="_blank" title="Newsletter"><span class="far tnt-envelope"></span></a></div><div class="col-item-icon"><a href="https://www.facebook.com/SkagitValleyHerald" target="_blank" title="Facebook"><span class="fab tnt-facebook-f"></span></a></div><div class="col-item-icon"><a href="http://www.twitter.com/goskagit" target="_blank" title="Twitter"><span class="fab tnt-twitter"></span></a></div><div class="col-item-icon"><a href="https://www.youtube.com/user/skagitvalleyherald" target="_blank" title="YouTube"><span class="fab tnt-youtube"></span></a></div></div>
            </div>
            <div style="clear:both;"></div>
        </div>
    </div></div><div id="tncms-block-1267249" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1267249"><div class="col-xs-12"><small>&copy; Copyright 2020 <a href="/">Skagit Valley Herald</a>, 1215 Anderson Road Mount Vernon, WA</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("fc2a311f-3ad2-5437-95d4-9aef5d7b3469")});});
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                	_cc9940.add('act', dmpData);
	_cc9940.bcp();

            });
        });
    </script>
    
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/png_core/resources/scripts/png.js?_dc=1589266897"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/scripts/main.js?_dc=1526409156"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/goskagit.com/content/tncms/live/libraries/flex/components/site/resources/scripts/jquery.matchHeight.js?_dc=1524077633"></script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            	_cc9940.add('act', serviceData);
	_cc9940.bcp();

                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        	_cc9940.add('act', dmpData);
	_cc9940.bcp();

                    }
                }
            }
         /*]]>*/</script></body>
</html>